Downloads

You should install operator's console to use our service. We offer 3 versions of software. You need 1 of this 3 consoles. If your operating system is Windows then we advise version 4.

Version 4

Windows users with modern PC should download LiveChatNow! operator's console version 4.

Version 4 requires .NET 2.0 available from Microsoft for free.

Old console (version 3)

Version 3 does not require .NET 2 and Java. Download LiveChatNow! operator's console version 3

Cross Platform console

Our new cross platform operator's console is available as pre release.

Requirements: Java 6 (Windows, Mac OS X, Linux or other operating system).

Mac OS X Attn: At this moment Mac OS X does not come with Java 6. However owners of Mac OS X with Intel 64bit processors (Core 2 Solo, Core 2 Duo, but not Core or Pentium) may download Java 6 for their Macs from apples website otherwise you should use Java 5 backport.

Mac OS X (Java 5 backport)

At this moment Mac OS X is not supplied with Java 6. We have backported console to work with Java 5. Use following button if your OS has Java 5 support only.

Requirements: Java 5 (Windows, Mac OS X, Linux or other operating system)

Android

Click download link to get android package. You must enabled unknown sources to install application from web.

You may also use that QR Code to download and install android console

BlackBerry

Click download link to download BlackBerry package.